Issues Loading Zoom Website
Incident Report for Zoom
Resolved
This incident has been resolved.
Posted Mar 24, 2022 - 17:52 PDT
Monitoring
We have resolved the issues causing some errors and latency intermittently when accessing the Zoom website (zoom.us). We will continue to monitor and provide updates as we have them.
Posted Mar 24, 2022 - 16:58 PDT
Investigating
We have received reports of some errors and latency intermittently when accessing the Zoom website (zoom.us). We are currently investigating and will provide updates as we have them.
Posted Mar 24, 2022 - 16:18 PDT
This incident affected: Zoom Website (Web Portal).