Issues calling in to the Kuwait Toll number
Incident Report for Zoom
Resolved
The issues of PSTN callers not being able to dial into the Kuwait number for Zoom meetings have been resolved by adding an additional number for Kuwait.
Posted Nov 30, 2018 - 16:18 PST
Investigating
We are investigating reports of PSTN callers not able to join Zoom meetings through the +965 2206 XXXX number. We are currently working with our providers to resolve the issue.
Posted Oct 24, 2018 - 09:03 PDT
This incident affected: Zoom Meetings (Meeting Dial-in/Telephony).