Billing and Subscription Issues
Incident Report for Zoom
Resolved
Our service provider has reported the issue as resolved, and we have confirmed that the service is working properly. All billing functions are fully operational.

Thank you for your patience while we worked to resolve this issue!
Posted Sep 14, 2017 - 19:18 PDT
Monitoring
Our service provider has resolved the issue and we have re-enabled the Billing functions on the Zoom website. We will continue to monitor to confirm that this issue is completely resolved, and report back once testing is complete.
Posted Sep 14, 2017 - 18:57 PDT
Investigating
Our payment service provider is currently experiencing issues with their service. This will cause errors when purchasing a new Zoom subscription, upgrading an existing Zoom subscription, and viewing billing and subscription information. We are working with our provider to get this service back up as quickly as possible, and will provide updates as they become available.
Posted Sep 14, 2017 - 18:15 PDT