Zoom Billing Services Unavailable
Incident Report for Zoom
Resolved
The Zoom's billing services are restored.
Posted Jan 25, 2020 - 03:00 PST
Monitoring
The Zoom's billing services are up and we are monitoring further.
Posted Jan 25, 2020 - 01:50 PST
Identified
Zoom's billing services are temporarily unavailable currently.It will impact the ability to add and modify existing Zoom subscriptions. Our service operation team is working with vendor to further troubleshoot the issue. We are sorry for any inconvenience.
Posted Jan 25, 2020 - 01:19 PST
This incident affected: Zoom Website (Download Center).