A subset of users may experience issues with multiple services in Saudi Arabia

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 22:40 PDT

Monitoring

We have fixed the issue where a subset of users may have experienced issues with multiple services in Saudi Arabia. We will continue to monitor & provide updates as soon as there is more information to share.
Posted Jul 16, 2025 - 22:20 PDT

Identified

We have identified the issue causing service degradation where a subset of users experienced issues with multiple services in Saudi Arabia. We observed issues from a segment of US traffic to Saudi Arabia. Our vendor is currently working on a fix. We will continue to provide updates as we have them.
Posted Jul 16, 2025 - 22:02 PDT

Investigating

We have detected service degradation where a subset of users may experience issues with multiple services in Saudi Arabia. Our engineers are currently investigating the impact and root cause. Zoom will provide updates as soon as there is more information to share.
Posted Jul 16, 2025 - 21:44 PDT
This incident affected: Zoom Rooms (Zoom Rooms), Zoom Chat (File Transfers: File, Video, Pictures, Voice, Zoom AIC), Zoom Website (Web Client), Zoom Meetings (Live Transcription, Zoom Conference Room Connector, Zoom Whiteboard, Zoom AIC), and Zoom Notes.