Issues Calling Zoom's Corporate Telephone Number
Incident Report for Zoom
Resolved
Issues calling Zoom's Corporate Telephone Number is resolved.
Posted Oct 11, 2018 - 09:50 PDT
Monitoring
We have restored service to our Corporate Telephone Number. We will continue to monitor to ensure stability.
Posted Oct 11, 2018 - 09:42 PDT
Update
We are continuing to investigate this issue.
Posted Oct 11, 2018 - 09:30 PDT
Investigating
We have had reports where users are unable to call into Zoom's Corporate Telephone Number to contact Billing, Sales, & Support. There is no impact to the Zoom Product and Zoom Cloud. Individuals can still successfully dial into Zoom meetings.

Our team is currently investigating and will provide updates as we have them. In the meantime, you can contact our Sales and Support teams live via chat at zoom.us or contact our Billing and Support teams via ticket at support.zoom.us
Posted Oct 11, 2018 - 09:00 PDT