Customers unable to purchase or make changes to subscriptions
Incident Report for Zoom
Resolved
The issues reported have been resolved.
Posted 12 days ago. Aug 07, 2019 - 10:25 PDT
Monitoring
Our vendor has resolved the issue, and all new subscriptions and changes to existing subscriptions should process as normal.
Posted 12 days ago. Aug 07, 2019 - 10:07 PDT
Investigating
We have received reports of customers unable to purchase new subscriptions or make additional make changes to their subscriptions. Our teams are working with our vendor to investigate.
Posted 12 days ago. Aug 07, 2019 - 08:45 PDT