Issue with Zoom Phone inbound calls for Mexico and Panama numbers
Incident Report for Zoom
Resolved
On 1/17/2025 from 18:26 UTC to 21:48 UTC, a subset of users may experienced inbound call issues with Mexico and Panama numbers on Zoom Phone. We have fixed this issue and the incident has been resolved.
Posted Jan 17, 2025 - 13:56 PST