Issue with Zoom Support Website
Incident Report for Zoom
Resolved
On 02/01/2025 from 6:05 UTC to 6:30 UTC, we experienced an issue with our support website (support.zoom.com). We have mitigated the issue. The incident has been resolved.
Posted Jan 31, 2025 - 22:30 PST