Issues calling Zoom's Corporate numbers
Incident Report for Zoom
Resolved
Our vendor has resolved the issue impacting Zoom's Corporate numbers for Sales, Support, and Billing. All channels are available.
Posted Jun 04, 2020 - 15:28 PDT
Identified
Our vendor has identified the root cause and is working towards full resolution. Customers may still experience intermittent issues calling Zoom's Corporate numbers. Our Chat and Ticket channels are still available. Zoom meeting and telephony services are not impacted.
Posted Jun 04, 2020 - 08:36 PDT
Investigating
We are currently investigating issues with dialing in to Zoom's Corporate numbers for Sales, Support, and Billing and are working with our vendor. This does not impact Zoom meeting services.
Posted Jun 04, 2020 - 07:51 PDT