Issue with Zoom Phone outbound calls in Europe.
Incident Report for Zoom
Resolved
On 1/21/2025 from 07:00 UTC to 13:57 UTC, a subset of Zoom Phone users might have experienced outbound call issue in Europe region. We have mitigated the issue and the incident has been resolved.
Posted Jan 21, 2025 - 06:50 PST