Issue with incoming calls in Zoom Phone
Incident Report for Zoom
Resolved
From 01:17 12-14-2024 UTC to 16:16 12-15-2024 UTC a subset of US customers' incoming calls were impacted. This issue has been resolved.
Posted Dec 15, 2024 - 09:11 PST