Issues making and receiving calls in Zoom Phone (US and CAN)
Incident Report for Zoom
Resolved
The Zoom Phone issues have been resolved.
Posted Mar 23, 2020 - 08:20 PDT
Monitoring
We have implemented further fixes for this issue, and all inbound and outbound calls through Zoom Phone in the US and CAN are working as expected. We will continue to monitor the results.
Posted Mar 20, 2020 - 09:10 PDT
Identified
We have implemented a fix for the issues making and receiving calls through Zoom Phone. Some customers may still experience a delay in connection when making and receiving calls. Our team is still working on a solution to this issue.
Posted Mar 18, 2020 - 11:37 PDT
Investigating
We have received reports of issues making and receiving calls through Zoom Phone in our US zones. Our engineering and operations teams are investigating.
Posted Mar 18, 2020 - 08:09 PDT
This incident affected: Zoom Phone - NORTH AMERICA (Zoom Phone).