Zoom Service Status

Issue with Zoom Rooms Web Controller in Germany.

Incident Report for Zoom

Resolved

On 03/29/2025, between 9:30 UTC to 9:58 UTC, a subset of customers might have experienced an issue with connecting to Zoom Rooms Web Controller in Germany. Our engineers have mitigated the issue. This incident has been resolved.
Posted 5 days ago. Mar 29, 2025 - 03:40 PDT