Zoom Service Status

A subset of users experiencing issues with multiple Zoom services in Saudi Arabia.

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted 2 months ago. May 27, 2025 - 07:05 PDT

Monitoring

We have resolved the concern causing a subset of users experience issues with multiple Zoom services in Saudi Arabia. We will continue to monitor and provide updates as we have them.
Posted 2 months ago. May 27, 2025 - 04:40 PDT

Identified

We have identified the concern causing a subset of users experience issues with multiple Zoom services in Saudi Arabia. We are currently investigating and we will provide updates as we have them.
Posted 2 months ago. May 27, 2025 - 04:31 PDT

Investigating

A subset of users experiencing issues with multiple Zoom services in Saudi Arabia. We are currently investigating and we will provide updates as we have them.
Posted 2 months ago. May 27, 2025 - 03:42 PDT
This incident affected: Zoom Rooms (Zoom Rooms), Zoom CX - EMEA (Zoom Contact Center), Zoom Clips, and Zoom Meetings (Zoom AIC).