Issue with the Zoom Billing
Incident Report for Zoom
Resolved
This incident has been resolved.
Posted Nov 28, 2024 - 02:42 PST
Monitoring
We have resolved the issue with Zoom billing portal. We will continue to monitor and provide updates as we have them.
Posted Nov 28, 2024 - 02:29 PST
Identified
Our monitoring has detected issues with Zoom billing portal, we have identified and investigating the issue. We will provide updates as we have them.
Posted Nov 28, 2024 - 01:55 PST
This incident affected: Zoom Website (Web Portal).