Zoom Service Status

Issue with Zoom's billing and payment pages

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted 10 months ago. Sep 04, 2024 - 13:27 PDT

Monitoring

The issue with Zoom's billing and payment pages has been resolved. We will continue to monitor and provide updates as we have them.
Posted 10 months ago. Sep 04, 2024 - 12:37 PDT

Identified

We have identified an issue with Zoom's billing and payment pages. We will provide updates as we have them.
Posted 10 months ago. Sep 04, 2024 - 11:46 PDT
This incident affected: Zoom Website (Web Portal) and Zoom Subscriptions.