A subset of users would be experiencing slowness when accessing our Web pages in Ohio region.

Incident Report for Zoom

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 00:57 PDT

Monitoring

We have fixed the issue where a subset of users were experiencing slowness when accessing our Web pages in Ohio region. We will continue to monitor & provide updates as soon as there is more information to share.
Posted Mar 11, 2025 - 00:10 PDT

Investigating

We have detected service degradation where a subset of users would be experiencing slowness when accessing our Web pages in Ohio region. Our engineers are currently investigating the impact and root cause. Zoom will provide updates as soon as there is more information to share.
Posted Mar 10, 2025 - 23:48 PDT
This incident affected: Zoom Contact Center - NORTH AMERICA (Zoom Contact Center) and Zoom Website (Web Portal).