issue with blog.zoom.US
Incident Report for Zoom
Resolved
Between 11:50 UTC and 18:05 UTC a subset of customers may have experienced an issue with blog.zoom.us
Posted May 26, 2023 - 11:34 PDT